Stax Bill Service Issue

Incident Report for Stax Bill

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:00 EST

Monitoring

We are seeing some signs of recovery for impacted systems. We will continue to monitor the situation closely.
Posted Nov 18, 2025 - 09:42 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 09:01 EST

Investigating

We have been made aware that Cloudflare is experiencing a global outage which is impacting the Stax Bill platform. Teams are actively working on the issue.
Posted Nov 18, 2025 - 07:45 EST
This incident affected: API, Admin Interface, Hosted Checkout Pages, Transparent Redirect, and Self Service Portal.