Service Disruption
Incident Report for Stax Bill
Resolved
This incident has been resolved.
Posted Aug 27, 2024 - 12:08 EDT
Identified
We have identified an issue related to payment methods that may impact validation. Our teams are working on a resolution and will continue to provide updates.
Posted Aug 26, 2024 - 15:11 EDT
This incident affected: Admin Interface, Hosted Checkout Pages, and Self Service Portal.