Billing Process Slowdown
Incident Report for Stax Bill
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 13:29 EDT
Monitoring
Stax Bill has become aware the the average processing time for individual Billing processes was impacted for today's run. Due to the increase in average processing time, the queue of invoices to process built up and some accounts didn't see any processing, as of 8:00 AM. Stax Bill engineers have found and fixed the underlying cause and the average processing time has been restored to optimal. The queue is clearing now and will complete no later than end of business today.
Posted Jun 01, 2023 - 10:43 EDT
This incident affected: Admin Interface.