Email Send Delay - Stax Bill

Incident Report for Stax Bill

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 11:39 EDT

Investigating

We are currently investigating a service disruption with Stax Bill Emails. Teams are working to identify the root cause and implement a solution. Please expect some delay in the delivery of emails from Stax Bill.
Posted Jul 24, 2025 - 10:55 EDT
This incident affected: Admin Interface.