Billing Run for Jun 20 running more slowly than normal
Incident Report for Stax Bill
Resolved
The billing run for Jan 20 has completed. There are no known problems associated.
Posted Jan 20, 2024 - 20:33 EST
Monitoring
Billing run is running still and expected to complete today.
Posted Jan 20, 2024 - 13:44 EST
Update
We are continuing to investigate this issue.
Posted Jan 20, 2024 - 11:06 EST
Investigating
Processing of the Billing Run for Jan 20 is running more slowly than normal. The engineering team is working on solutions to processing delays. Some of the billing for Jan 20 had already finished.
Posted Jan 20, 2024 - 10:45 EST
This incident affected: Admin Interface.