Subscription Management Functions not functional
Incident Report for Stax Bill
Resolved
This incident has been resolved.
Posted Feb 18, 2023 - 22:02 EST
Investigating
We are currently investigating failures to load subscriptions and subscription products into the Admin UI (admin.staxbill.com). Subscription products will not load into the interface and an "Error retrieving products" message is display.
Subscription management via API is also affected.
At this time we are not aware of any other functions in the Admin UI or with the API or other Stax Bill systems.
Posted Feb 18, 2023 - 18:42 EST
This incident affected: API and Admin Interface.