Billing and Invoice Post not completing
Incident Report for Stax Bill
Resolved
The backlog of Billing operations has now completed for all production accounts.
Posted Mar 22, 2024 - 11:17 EDT
Monitoring
The problem with the billing run has been addressed and the backlog is catching up now. We expect that it will catch up and finish all outstanding billing operations in 1 to 2 hours.
We will post again once the process is finished.
Posted Mar 22, 2024 - 10:47 EDT
Investigating
At this time Stax Bill is working on an issue with our automated Billing service. Actions related to subscription renewal, including Invoice Creation and Payments are failing to complete for some accounts. We are actively working on this issue and will update here as
Posted Mar 22, 2024 - 10:32 EDT
This incident affected: Admin Interface.