Funding Delay

Incident Report for Stax Bill

Resolved

This incident is now resolved.
Posted Mar 04, 2026 - 11:30 EST

Update

The Federal Reserve has completed remediation of the impacted services. We have been informed that settlement funding for the March 2nd and March 3rd business days may still be delayed.
Posted Mar 03, 2026 - 14:21 EST

Monitoring

The Federal Reserve has acknowledged that remediation of the issue is underway. Merchants can expect settlement funding for transactions taken on March 3rd to also be impacted.
Posted Mar 03, 2026 - 10:55 EST